Page MenuHomeMiraheze

Visual editor template SVG issue
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Go to my user page on miraheze meta, at the top of the page you should see the word working and a small image to its left. That's actually a template
  2. Click edit
  3. You'll see that image suddenly enlarged when you're in VE edit mode
  4. Optional: Go to WP sandbox, try to insert the "Working" template and you'll see that the enlargement problem doesn't exist there while editing

Event Timeline

Calnation created this task.Feb 7 2017, 04:54
Calnation created this object in space S1 Public.
Void moved this task from Backlog to Bugs on the MediaWiki board.
Calnation added a comment.EditedFeb 14 2017, 00:07

I'd like to request that this ticket's priority is elevated. I do all my editing using the visual editor and currently, I'm using many templates from en:WP and this bug makes my task 10x harder. To give you a glimpse of what I'm facing, please see here how a couple of small icons can make editing a difficult task.

Trevor raised the priority of this task from Normal to High.Feb 14 2017, 00:19
Trevor added a subscriber: Trevor.

I'd like to request that this ticket's priority is elevated.

Done. I understand your frustration. Hopefully the bug reports like this one will be given attention as soon as possible.

Void added a comment.Feb 14 2017, 01:21

Trouble is, this might be an Upstream issue (which could take months to get a solid response on).

@Void How so? Bug doesn't appear at all on en:WP

Void added a comment.Feb 14 2017, 01:48

I said might. I rarely touch the visual editor.

FYI, I just reported T1437: Visual editor Graph issue
Not sure if it's connected or not.

Reception123 lowered the priority of this task from High to Normal.Feb 15 2017, 15:54
Reception123 added a project: Upstream.

@Calnation Void is probably right about Upstream. The thing is Wikipedia is running on a the Beta version of Mediawiki (1.29) and therefore a different version of VisualEditor (beta 1.29). Miraheze only upgrades when Mediawiki versions are released, so this issue will probably only be fixed then.
Tagging as normal due to upstream.

Based on my comment above, I request Upstream tag be removed. I urge more investigation next time before that tag is used anywhere else.

John added a subscriber: John.Feb 17 2017, 18:15

I've looked into this and I am sure it is upstream.

When editing the images in VisualEditor on Miraheze - it says the defined size is 150px. When viewing it on Vikidia, it says the defined image size is 20px. The wikitext is identical however. When I change our size to 20px, it wants to use 20x20px instead of 20px in the wikitext which is still valid.

I believe this is an issue in parsoid's rendering since I've never seen this issue until now even on Miraheze.

John claimed this task.
John added projects: Services, Operations.

I'll find some time and try and grab some time with a parsoid developer and see if we can narrow this issue down.

John removed a project: Services.Feb 22 2017, 17:21

Dropping parsoid as this is no longer the issue.

The issue is Commons is returning 150px as the height of the image so this is still an upstream issue currently until we can be sure it's on our side and I'll try my best to resolve this as soon as.

John removed John as the assignee of this task.Feb 23 2017, 17:44

Now dropping my assign. I've had a look and I can't see anything. More so this is MediaWiki which is outside of my area of expertise so I'm not the most useful person to investigate this.

Calnation removed a subscriber: Calnation.Mar 7 2017, 07:09
Amanda edited projects, added Extensions; removed MediaWiki.Apr 18 2017, 19:49
Amanda moved this task from Needs Review to Bugs on the Extensions board.
Amanda added a subscriber: Amanda.

This is specifically a bug with an extension rather than MediaWiki as a whole

John edited projects, added MediaWiki; removed Extensions, Operations.Apr 18 2017, 20:07

No, this is 100% MediaWiki API.

Zppix added a subscriber: Zppix.Jun 12 2017, 16:04

@John I will talk to Wikimedia collegues I have, and i will get back to you :)

John changed the task status from Open to Stalled.Aug 14 2017, 13:46
John lowered the priority of this task from Normal to Low.
Zppix added a comment.Aug 14 2017, 17:38

I will file an upstream task, keep this one open as I will update here aswell.

Zppix added a comment.Aug 15 2017, 13:38

Upstream says it may be parsoid, so they are investigating now.

Zppix added a comment.EditedSep 9 2017, 16:41

Upstream says: See my response from above. The MediaWiki API at meta.miraheze.org is telling Parsoid that the thumbwidth and thumbheight should be 150px.

My guess is that you don't have whatever software is necessary to scale an SVG installed on that server, so it's just returning the image size, even though it has asked for 20px.
See https://www.mediawiki.org/wiki/Manual:$wgSVGConverter

John added a comment.Sep 10 2017, 16:17

Nope, all that is correct and we can (have and do) scale SVGs.

Zppix added a comment.Sep 10 2017, 16:30

@John Telling upstream, will update

Zppix added a comment.Sep 10 2017, 19:44

upstream says:
Ok, so I can reproduce this locally now.

It's the result of having NativeSvgHandler enabled.

This issue is still a problem, I think. I still get very enlarged vectors when they are put in templates on my personal wiki. It is kind of a pain but I get by. Any other news on this? @Zppix

Ucronistaw added a comment.EditedMar 5 2018, 21:38

Ibidem @CnocBride, ¿hay novedades?

Paladox added a subscriber: Paladox.Aug 12 2018, 19:03

We should uninstall NativeSvgHandler seeing as that's the problem.

John assigned this task to Paladox.Thu, Dec 6, 17:47

We should uninstall NativeSvgHandler seeing as that's the problem.

Paladox closed this task as Resolved.Sat, Dec 8, 15:51