Page MenuHomeMiraheze

bp wiki ProofreadPage issues
Closed, ResolvedPublic

Event Timeline

Jayvdb created this task.May 20 2017, 04:14

since he has been involved in the bpwiki import

Void triaged this task as Normal priority.May 20 2017, 17:40
Reception123 moved this task from Backlog to Bugs on the Extensions board.May 21 2017, 16:02
Reception123 mentioned this in Unknown Object (Diffusion Commit).Jun 3 2017, 10:21

The version used by WikiSource is different from Miraheze, so it is possible that's why it works there and not here (but unlikely). MediaWiki 1.29 should be coming out soon, but I will continue investigating this issue.

Jayvdb added a comment.Jul 16 2017, 02:05

MediaWiki 1.29 is out, and Wikisource.org is currently running ProofreadPage on this hash.

WMID has decided to put the https://bp.miraheze.org go live on hold temporarily, until most of the software is working correctly.
If it turns out that upgrading doesn't resolve the issue, easily, WMID try to help by allocating someone to investigate replicating and identifying the problem.

Jayvdb added a comment.Aug 14 2017, 11:28

The upgrade to MediaWiki 1.29 has happened.

And DJVU files are still a problem.
Is djvulibre installed?
https://phabricator.wikimedia.org/T70638 is maybe related.

I notice that djvu tools are not listed on https://en.wikisource.org/wiki/Special:Version , whereas the LilyPond version is mentioned. Maybe that should be added upstream to help users see the status of this?

the library was installed by John but seems like the issue is still not resolved so you might want to ask someone from WMID to investigate.

John added a comment.Aug 20 2017, 15:52

Nothing to be investigated, more looking shows the only issue is that the thumbs aren't generated is the issue.

John added a comment.Aug 22 2017, 09:54

Indeed they should be. I've not had to look into why they're not unfortunately.

Reception123 mentioned this in Unknown Object (Diffusion Commit).Aug 23 2017, 16:00
John assigned this task to Reception123.Aug 30 2017, 18:47

I asked Reception to investigate the generation of thumbnails, as its a MediaWiki-ish thing this is more likely his area over mine. With an assign, it guarantees some movement and frees me up for other things.

Reception123 mentioned this in Unknown Object (Diffusion Commit).Aug 31 2017, 14:11

Oh yes, this was stuck on that rewrite PR that confused me, and I still can't tell what to do with the location dir on it.

The issue has been identified. It is due to the files being uploaded prior to the djvu libraries actually being installed, so all that needs to be done is an overwrite of the files to fix the thumbnails.

This is waiting on @John as for some reason the bpwiki folder is "nogroup" instead of "www-data".

Reception123 closed this task as Resolved.Sep 2 2017, 10:58

@Jayvdb Re-import of all DjVu files is happening and everything should be working as expected once that's done. (can confirm that the page that you linked is now showing the image).

Thanks to @John for helping out.

Reception123 reopened this task as Open.Sep 2 2017, 12:15
This comment was removed by Reception123.
Reception123 closed this task as Resolved.Sep 2 2017, 16:59

And resolved again..

John added a comment.Sep 2 2017, 16:59

Pot. disk space related?

Definitely, since after the thumbs were deleted it was fixed.