Page MenuHomeMiraheze

bp.miraheze.org contributions lost
Closed, ResolvedPublic

Description

@Rachmat04 and Siska have logged into bp.miraheze.org, and their contributions disappeared.

Rachmat04 was a while ago, and I noticed it then, but wanted to try it with another user before raising the issue.

Today I stepped Siska through the process, monitoring her contributions list at each step.

After login to meta.miraheze, her bp.org contributions were still visible at https://bp.miraheze.org/wiki/Istimewa:Kontribusi_pengguna/Siska, but her username was still greyed out.
After she visited bp.miraheze.org whilst logged in, CentralAuth created her Siska account on bp.miraheze , and https://bp.miraheze.org/wiki/Istimewa:Kontribusi_pengguna/Siska became empty with her username now a redlink.

If the fix is not easy, it would be helpful for Rachmat04's contributions to be manually fixed, so his account is 'OK', as he will be doing some of the UAT for the migration project.

Event Timeline

Jayvdb created this task.May 24 2017, 09:09
Jayvdb updated the task description. (Show Details)May 24 2017, 09:27
Reception123 triaged this task as High priority.May 25 2017, 05:41
Reception123 added subscribers: NDKilla, Reception123.

Needs to be dealt with by @Southparkfan or @NDKilla

Reception123 closed this task as Resolved.May 28 2017, 18:40
Reception123 claimed this task.

Contributions are now added back. This error might happen to other new users, if so please reopen this task and I will take care of it. Sorry for the wait.

Jayvdb reopened this task as Open.EditedMay 29 2017, 08:59

@Rachmat04 can not access bp.miraheze.org. The error is:

Kesalahan Hak Akses
Anda tidak memiliki hak akses untuk membaca halaman ini, karena alasan berikut:
Tindakan yang Anda minta dibatasi untuk pengguna dalam kelompok: Pengurus, Members.

translation:

Access Rights Error
You do not have permission to read this page, for the following reasons:
The action you have requested is limited to users in groups: Managers, Members.

Also , "This error might happen to other new users" is not acceptable for our users. It is confusing. It will result in them trying to fix the problem themelves, and some creating new accounts, causing new problems for our user migration strategy.

If the bug hasn't been fixed, please do not close this.
If necessary to workaround this, we can create accounts for everyone who has contribs manually and fix their contribs at the same time.

In T1830#34262, @Jayvdb wrote:

@Rachmat04 can not access bp.miraheze.org. The error is:

Kesalahan Hak Akses
Anda tidak memiliki hak akses untuk membaca halaman ini, karena alasan berikut:
Tindakan yang Anda minta dibatasi untuk pengguna dalam kelompok: Pengurus, Members.

translation:

Access Rights Error
You do not have permission to read this page, for the following reasons:
The action you have requested is limited to users in groups: Managers, Members.

Tracked in T1843 - new bug for new things ;)

Reception123 lowered the priority of this task from High to Normal.Jun 5 2017, 05:50

There is no longer a permanent "error", and a list of users to match contributions to can be provided as well as subtasks can be created for different issues.

Jayvdb raised the priority of this task from Normal to High.Jun 5 2017, 08:05

This happens for *every* migrated account (so far) when they log in.
That means it is a permanent error still.
Until a migrated user can log in and their contributions are not lost, this problem hasnt been solved and subtasks are only solving individual cases.
We have two more wikis to migrate after this one (and those wikis have more users and a longer history that bp), and doing each account one by one after they log in is a communication/coordination nightmare.

I'm sorry about this issue. The only thing that we can do is do it manually really (as we can't import user tables as-is). I'd be happy to migrate any users needed provided that I have a list of them.

Jayvdb added a comment.Jun 5 2017, 08:48

I'm sorry about this issue. The only thing that we can do is do it manually really (as we can't import user tables as-is). I'd be happy to migrate any users needed provided that I have a list of them.

They are in user table dump that Miraheze has/had.
Alternatively, I can provide the list of usernames here.

If there is any way that my team can help create these accounts, we'd be very happy to help do any boring work required in order to make our users adoption of Miraheze as easy as possible.

It seems like there is a bug in CentralAuth somewhere, or a missing feature, or an existing feature which isnt enabled. Maybe we can fix that? (I have technical staff who may be able to pull it off.

If you created the user accounts, would they be sent an email when it is created, and be required to change their password?

If so, we should see if we can fix T1813 first, otherwise they will log in and be worried about the state of their prior work.

And it wouldnt hurt to do T1875 too, before emails are sent out from the server.

@Jayvdb

No worries about the "boring work", that's what volunteers have to do sometimes ;)

I don't think the bug is with CentralAuth, it is more rather since the user table itself "user" has not been imported, the users are created but their IDs are not associated with the revision IDs. I will now take all users currently in the "user" table and associate them with the revision user IDs. As more users register on Miraheze, please let me know so I can associate those as well.

User account creation is your choice, either the users can create the accounts using Special:CreateAccount or you can give me a list of emails and desired account names to which I can send passwords to.

As you say you have technical staff, maybe they could assist us with fixing T1813? I'm not quite sure what the issue is, and help would be appreciated!

I'll look into T1875.

Only one user in the current user table (users who are registered on bpwiki) was still missing revisions, Biyanto, and I have associated them.

Ah, I have misread "They are in user table dump that Miraheze has/had." - you meant the old table.

I will ask @John if he can send it, as he should have it.

John added a comment.Jun 5 2017, 10:18

It will be on db2 if it wasn't deleted without my knowledge.

@Jayvdb On second thought, could you please provide the list here?

@Jayvdb Any updates on this?

Jayvdb added a comment.Jul 16 2017, 02:18

Hi, yes we've mostly finished aligning the usernames across the three sites to be migrated.

However due to https://phabricator.miraheze.org/T1813#37316 , we're not going to pursue activating accounts on the bp site at the moment.
However, there are three bp users whose accounts should be activated while we wait for the site issues to be resolved.
I've sent to you an email, listing the email addresses of these three:

  • Cahyo
  • Crisco_1492
  • Kumincir

Please note that these users have already been associated previously, and if you check you can see that their contributions do show up. For "Cahyo" I'm not sure if they had more edits than is shown, but if that is the case, please tell me (and preferably point me to a page) so I can fix the problem.

Jayvdb added a comment.Jul 16 2017, 17:48

No, they havent. Their accounts are all currently not real accounts. See

As soon as these users create an account on Miraheze, their contributions on bp will be lost per this task.

@Jayvdb Sorry for the delay. They have now been migrated and should be working.

@Jayvdb Since this task is still classified as high priority, do you have other users you need me to link?

Jayvdb lowered the priority of this task from High to Low.Aug 21 2017, 08:21

Sorry I will check those. The remainder of the problem is 'low' priority, as this is blocked on a few other issues being solved first.

OK, I will keep my assign since associated the accounts is easy and I don't think anyone else will do it before me, so I'll just wait for the next list of users. Comments have been made for the other issue.

John closed this task as Resolved.May 28 2018, 18:42

Dead-task.