Page MenuHomeMiraheze

bp.miraheze.org ProofreadPage Index pages
Closed, ResolvedPublic

Description

The ProofreadPage extension "Index" namespace appears to be not yet configured for https://bp.miraheze.org , and the old page titles have been mangled.

Here is the documentation of it: https://www.mediawiki.org/wiki/Extension:Proofread_Page#Configuration_of_index_namespace

There is only one entry appearing in Special:IndexPages, which is this one, which was created very recently ( 5 September 2017 ).

All of the old Index pages should appear there.

According to https://bebaskanpengetahuan.org/wiki/Bebaskan_Pengetahuan:Sumber_bacaan , there were many Index pages in namespace Indeks , and they are now in a strange condition findable via https://bp.miraheze.org/wiki/Kategori:Indeks_yang_statusnya_tidak_diketahui - it appears these pages found their way into namespace 0 with a trailing :.

Please configure the namespace to be called Indeks , and set it up in ProofreadPage.

Then we could manually move all the pages in https://bp.miraheze.org/wiki/Kategori:Indeks_yang_statusnya_tidak_diketahui to their proper names, but if it is easy to do in the database that would be nice ;-)

Event Timeline

Jayvdb created this task.Sep 18 2017, 02:16
Jayvdb added a comment.Sep 18 2017, 02:26

Also I believe that the "Page" namespace was previously named "Halaman", as that was the name on Indonesian Wikisource ; see https://id.wikisource.org/wiki/Halaman:UU_No._28_Tahun_2014.djvu/12 .
@Rachmat04 , can you confirm that?

Jayvdb added a comment.Sep 18 2017, 02:53

I can confirm that there are problems with the "Page" namespace also, but I am not sure how to interpret this.

There is https://bebaskanpengetahuan.org/wiki/Index:Horison_Oktober_1974.djvu
which links to https://bp.miraheze.org/wiki/Page:Horison_Oktober_1974.djvu/1 created 9 Juni 2016 04.46‎, size +397 , wgArticleId 49812

There is also https://bebaskanpengetahuan.org/w/index.php?title=Horison_Oktober_1974.djvu:&action=history
and https://bebaskanpengetahuan.org/wiki/Horison_Oktober_1974.djvu/1: also created 9 Juni 2016 04.46‎, size +516 , wgArticleId 42583

The content of the two pages is identical, so I am inclined to think these were actually a single page table entry in the old database, and the fact I am seeing two is due to the migration. (I only have the huge .sql file to check, and my quick reading of the .sql doesnt show there were two pages.)

In T2196#41373, @Jayvdb wrote:

Also I believe that the "Page" namespace was previously named "Halaman", as that was the name on Indonesian Wikisource ; see https://id.wikisource.org/wiki/Halaman:UU_No._28_Tahun_2014.djvu/12 .
@Rachmat04 , can you confirm that?

Yes, namespace "Page" may be changed to "Halaman" to conform Indonesian language version.

Jayvdb added a comment.Sep 18 2017, 03:25

I've loaded up the LocalSettings.php sent to me, and it had the following

define(NS_PROOFREAD_PAGE, 250);
define(NS_PROOFREAD_PAGE_TALK, 251);
define(NS_PROOFREAD_INDEX, 252);
define(NS_PROOFREAD_INDEX_TALK, 253);
$wgExtraNamespace[NS_PROOFREAD_PAGE] = "Page";
$wgExtraNamespace[NS_PROOFREAD_PAGE_TALK] = "Page talk";
$wgExtraNamespace[NS_PROOFREAD_INDEX] = "Index";
$wgExtraNamespace[NS_PROOFREAD_INDEX_TALK] = "Index talk";
$wgProofreadPageNamespaceIds = array(
    'index' => NS_PROOFREAD_INDEX,
    'page' => NS_PROOFREAD_PAGE
);

I guess that means the old configuration was 'incorrect' (especially Index vs Indeks namespace), but somehow it worked ok previously, and now the new version of MediaWiki & ProofreadPage do not function correctly with this misconfiguration.

Reception123 added a comment.EditedOct 31 2017, 15:23

@Jayvdb @Rachmat04 "Please configure the namespace to be called Indeks , and set it up in ProofreadPage." - I'm not sure for here, do you want a separate one called "INDEKS" and to keep

	$wgExtraNamespaces[NS_PROOFREAD_INDEX] = 'Index';

or do you want me to replace Index with Indeks?

For the configuration it should be configured, here: https://github.com/miraheze/mw-config/blob/9b4767d8659136d212535619e33326e1e1af845c/LocalExtensions.php#L434

And my understanding is you would also like me to rename NS_PROOFREAD_PAGE to "Halaman" instead of "Page"?

Jayvdb added a comment.Oct 31 2017, 15:42

I think we'll need to see how WMF has configured the new ProofreadPage to work on https://id.wikisource.org/ , as that is the configuration that is desired for https://bp.miraheze.org/ .
Indeks is just the Indonesian language translation for the Index namespace. The alias and the real namespace name should work identically.
See https://id.wikisource.org/wiki/Indeks:Permendikbud_No._11_Tahun_2015.pdf and https://id.wikisource.org/wiki/Index:Permendikbud_No._11_Tahun_2015.pdf
Likewise Halaman and Page.

@Jayvdb I have created aliases for the pages. Please tell me if it works as intended now.

Reception123 mentioned this in Unknown Object (Diffusion Commit).Oct 31 2017, 16:06
Jayvdb added a comment.Nov 1 2017, 08:01

ok, everything is looking much more like it is supposed it.
One problem is that https://bebaskanpengetahuan.org/wiki/Istimewa:IndexPages still only contained one entry.
I manually edited an Index page, and it appeared there, so that is one way to fix the problem.
I purged another, and it did not appear, so that doesnt appear to be a solution.
However I do not see a maintenance script to automatically fix that in https://github.com/wikimedia/mediawiki-extensions-ProofreadPage/tree/master/maintenance
Is there some other way, to automatically 'edit' those pages so that they appear in https://bebaskanpengetahuan.org/wiki/Istimewa:IndexPages

A script needs to be written to use https://www.mediawiki.org/wiki/Manual:Edit.php on the multiple pages.

@Jayvdb I ran the script and all pages in the "index" namespace now appear in Special:IndexPages.

Jayvdb closed this task as Resolved.Nov 3 2017, 06:41

Great. I think this issue is done.
@Rachmat04 is checking the wiki contents.
We'll create new issues for anything else, and then we can finish the usernames.