Page MenuHomeMiraheze

Interwiki template transclusion not working
Closed, InvalidPublic

Description

I've added links here to Infobox examples: If a wiki already has modules interwiki transclusion from templatewiki works okay but if it's a new wiki with nothing imported from Wikipedia it doesn't work, (with Script error: No such module "Infobox".).

Event Timeline

Rob_Kam created this task.Feb 7 2018, 11:44
Rob_Kam updated the task description. (Show Details)Feb 7 2018, 11:47

It's because Scribunto is required for modules.

revi moved this task from Feature Requests to Other on the Configuration board.Feb 7 2018, 14:22
revi triaged this task as Low priority.
Void added a comment.Feb 7 2018, 16:04

Isn't Scribunto enabled on all wikis by default? The issue, as I see it, is that using raw interwiki transclusion actually just posts the raw wikitext. Meaning that the local resources are used for displaying the template, instead of the resources from templatewiki.

The issue is that wgEnableScaryTranscluding needs to be set to true

Rob_Kam added a comment.Apr 14 2018, 08:20

wgEnableScaryTranscluding is already set to true in LocalSettings.php#L3557.

John closed this task as Invalid.May 28 2018, 19:17
John added a subscriber: John.

I'm going to close this because I get the feeling it's because the way the template is designed, it's looking for Module:Infoxbox, and when you transclude it, the transclusion of "Module:Infobox" still applies, meaning no matter where you get it from, it will always look for Module:Infobox on the local wiki.

Therefore this isn't a tech ticket but a issue to be resolved on templatewiki.