Page MenuHomeMiraheze

Making Weather Wiki private for only unregistered users
Closed, ResolvedPublic

Description

I want my wiki - weather.miraheze.org, to be private for only unregistered users. This means that users who are not logged in should only be able to see the main page and the whitelisted special pages, while users who are logged in, regardless of membership of any additional groups, should have full access to the wiki.

In rMWCFdb0177a9f3c3 I pushed the configuration for this to take effect, as if I remember correctly I’m not allowed to just set $wgGroupPermissions[‘*’][‘read’]=false on a public wiki. In addition to pushing the above code, I also flagged the wiki as private in Special:ManageWiki, even though it’s only private to anonymous users.

The above configuration changes almost have worked as intended, with one major problem. The “user” group still does not have the read permission, even though I explicitly granted it in LocalSettings.php and I unset the member group in LocalWiki.php.

Please correct this as soon as possible, as this is disrupting my entire wiki (and therefore is high priority). To recap, the ultimate goal is to have all registered users able to read the wiki in full, but unregistered users unable to read any pages except those whitelisted for private wikis.

Event Timeline

AmandaCath triaged this task as High priority.
John added a comment.Aug 1 2018, 07:22

read from user is revoked in LocalWiki therefore you have to assign read to user in LocalWiki.

John added a comment.Aug 1 2018, 07:42
In T3438#64998, @revi wrote:

This is making a private wiki semi-public not a public wiki semi-private.

MacFan4000 lowered the priority of this task from High to Normal.Aug 1 2018, 10:16

Not urgent. - nothing is preventing the site from working

John added a comment.Aug 1 2018, 10:25

Not urgent. - nothing is preventing the site from working

Except the fact no one read it?

John closed this task as Resolved.Aug 1 2018, 10:26
John claimed this task.

Now resolved.

Rather poor showing for a resolution though.