Page MenuHomeMiraheze

Also show page holding the rotten link
Closed, ResolvedPublic

Description

Setup

  • MediaWiki 1.31.1 (8635864) 19:51, 15. Okt. 2018
  • PHP 7.0.30-0+deb9u1 (apache2handler)
  • MariaDB 10.1.26-MariaDB-0+deb9u1
  • RottenLinks 1.0.1 (c7f4466) 20:48, 16. Okt. 2018

Issue
Special page "Rotten links" shows the rotten link but it does not show on which page the rotten link may be found. Thus it will be great to have an extra column showing the page. I think this column should be first one, then the rotten link, etc.

Event Timeline

Kghbln created this task.Oct 16 2018, 20:08
Kghbln updated the task description. (Show Details)Oct 16 2018, 20:09
Paladox edited projects, added RottenLinks; removed Configuration.Oct 16 2018, 20:26
John claimed this task.Oct 16 2018, 21:32
John added a subscriber: John.

T2069#70886

Was already an identified TODO, this just tasks it. My plan is to make the "page usage" number a link which will then either pop up a formatted list of the pages it is used on or a redirect to a page with a list.

Kghbln added a comment.Oct 16 2018, 21:42

Was already an identified TODO, this just tasks it. My plan is to make the "page usage" number a link which will then either pop up a formatted list of the pages it is used on or a redirect to a page with a list.

Great. This spares you from creating the tasks. :) I think from a usability point of view it will be better to have a redirect to a page with a list of the respective pages.

AmandaCath renamed this task from Extension:RottenLinks - Special:RottenLinks - Also show page holding the rotten link to Also show page holding the rotten link.Oct 20 2018, 19:10
John closed this task as Resolved.Nov 1 2018, 01:39
Kghbln reopened this task as Open.Nov 1 2018, 17:17

First of all thanks a lot for working on the extension. I just updated my wiki to use the latest version and most of the issues have been addressed in a cool way. Very much appreciated. :)

This one however does not yet work, e.g. for a link like http://examlple.org/%E3%82%88%E3%81%86%E3%81%93%E3%81%9D I get the following link when clicking on the number in the "Page Usage" column: https://example.org/w/Special:LinkSearch/http://examlple.org/%E3%82%88%E3%81%86%E3%81%93%E3%81%9D which in turn redirects me to "Main Page" of the wiki instead to a subpage showing the pages holding the rotten links.

Kghbln added a comment.EditedNov 1 2018, 17:34

Ah I get it. The issue is that the link is not being added properly to special page "LinkSearch" so an invalid url is constructed which in my case gets redirected via an Apache rule to "Main Page". If I go to the special page and manually add the rotten link then I get the list of pages. I must note that the configured language of the wiki instance is "fr" so the special page is called "Recherche de lien". Perhaps this is the reason. Anyways a smart idea to use this special page to do the work.

John added a comment.Nov 1 2018, 17:40

I know the issue, I didn't construct the script URL correct, it should go to index.php :)

Kghbln added a comment.Nov 1 2018, 17:41

You are the best. :)

John closed this task as Resolved.Nov 1 2018, 17:43
Kghbln added a comment.Nov 1 2018, 17:48

Cool. I just updated and it works now. Many kudos!!!