Page MenuHomeMiraheze

Errors with VisualEditor and MsUpload
Closed, InvalidPublic

Description

Hey,

We are unable to save changes/upload files to our wiki's articles through Visual Editor. We're getting these two errors ("unknown error" and "parsererror"):



Concerning MsUpload on CodeEditor, everything is working great, the files are uploaded successfully although we get a warning message like the one below. This warning is issued for every file regardless if it's new or has already been uploaded.

Full warning:

Error: {"warnings":{"main":{"*":"Unrecognized parameter: name."}},"upload":{"result":"Success","filename":"Warningupload.png","imageinfo":{"timestamp":"2018-10-21T16:16:51Z","user":"Sysadmin wannabe","userid":1,"size":43548,"width":1338,"height":196,"parsedcomment":"File uploaded with MsUpload","comment":"File uploaded with MsUpload","html":"A file with this name exists already, please check Ficheiro:Warningupload.png if you are not sure if you want to change it.\n\n \n","canonicaltitle":"Ficheiro:Warningupload.png","url":"https://static.miraheze.org/checkinwiki/e/e6/Warningupload.png","descriptionurl":"https://checkin.miraheze.org/wiki/Ficheiro:Warningupload.png","descriptionshorturl":"https://checkin.miraheze.org/w/index.php?curid=0","sha1":"c4b50955a45b2dfa7a827807af1dbb643357d0e5","metadata":[{"name":"frameCount","value":0},{"name":"loopCount","value":1},{"name":"duration","value":0},{"name":"bitDepth","value":8},{"name":"colorType","value":"truecolour-alpha"},{"name":"metadata","value":[{"name":"_MW_PNG_VERSION","value":1}]}],"commonmetadata":[],"extmetadata":{"DateTime":{"value":"2018-10-21T16:16:51Z","source":"mediawiki-metadata","hidden":""},"ObjectName":{"value":"Warningupload","source":"mediawiki-metadata","hidden":""}},"mime":"image/png","mediatype":"BITMAP","bitdepth":8}}}{"username": ["Must be between 2 and 32 in length."]}

Actual error?

{"username": ["Must be between 2 and 32 in length."]}

Thank you for your awesome service and support.

Event Timeline

Unknown Object (User) created this task.Oct 21 2018, 17:08
AmandaCath triaged this task as High priority.EditedOct 21 2018, 19:03
AmandaCath added a project: Extensions.
AmandaCath added subscribers: John, NDKilla, Paladox, AmandaCath.

This appears to be a (fairly serious) bug with the VE and MsUpload extensions that needs attention. Unfortunately, you may need to disable the VisualEditor and MsUpload until a fix is created/found.

AmandaCath renamed this task from Visual Editor (NOK) - Error: parsererror | MsUpload (OK) - Warning: {"username": ["Must be between 2 and 32 in length."]} to Errors with VisualEditor and MsUpload.Oct 21 2018, 19:03
AmandaCath moved this task from Backlog to Bugs on the Extensions board.
Unknown Object (User) added a comment.EditedOct 23 2018, 00:13
{"username": ["Must be between 2 and 32 in length."]}

Hey, just a follow-up. Actually, this error is not exclusive when uploading files with MsUpload. It's a global error. We also get it after an article is deleted.

Hmm.. I’m investigating. Please stand by.

@psiconauta I am unable to reproduce this on my wiki.

Unknown Object (User) added a comment.Oct 24 2018, 10:49

@AmandaCath, how can I help you guys troubleshooting?

Paladox added a comment.Oct 24 2018, 10:54

Could the file be conflicting with commons.wikimedia.org?

Unknown Object (User) added a comment.Oct 24 2018, 11:49

I'm afraid not because We get the warning for every file.

Paladox added a comment.Oct 24 2018, 16:26

It works for me uploading a image to your wiki.

Could you provide the exact steps you did please?

Unknown Object (User) added a comment.Oct 27 2018, 16:58

@Paladox deleted my wiki and created a new one but that did not solve the parser errors from VE. Apparently, this bug is solved on MW's version 1.32.
I'm trying to reproduce this issue on my dev env.

Unknown Object (User) closed this task as Resolved.EditedOct 27 2018, 19:47
Unknown Object (User) claimed this task.

So, @Paladox figured this out! The problem (don't ask how this happened) is with my username. Everything is working perfectly after We restored our wiki, requested from another user.
THANK YOU @Paladox for your time and dedication.

Unknown Object (User) reopened this task as Open.Oct 28 2018, 00:44

After all, this seems a bigger problem. Opened https://phabricator.wikimedia.org/T208157.

MacFan4000 lowered the priority of this task from High to Low.Oct 30 2018, 00:32
MacFan4000 added a project: Upstream.
John closed this task as Invalid.Oct 30 2018, 01:07

Bug report upstream, fix would require no action from us so this task achieves nothing here.