Page MenuHomeMiraheze

Page renders strangely on Mobile View
Closed, ResolvedPublic

Description

https://triglav.miraheze.org/wiki/Test

and https://triglav.m.miraheze.org/wiki/Test

All of my Wiki pages except for the main page renders strangely in Mobile View. For example, all the headers are right-aligned instead of left-aligned and on iOS they are squished and broken out as shown in the screenshot above.

The thing is this started happening after I installed Tweeki skin and reverted back to Vector skin. I've tried other skins to see if the problem would go away, but the Mobile View still renders incorrectly no matter the skin I choose.

Event Timeline

Xenic triaged this task as Normal priority.Nov 2 2018, 04:10
Xenic created this task.
AmandaCath moved this task from Backlog to Bugs on the MediaWiki board.
AmandaCath added a subscriber: AmandaCath.

This isn’t a design issue... sounds like an issue with one or more skins (which is categorized as extensions here).

Xenic added a comment.Nov 2 2018, 23:36

Is there a way for me to "reset" mobile view?

Paladox added a subscriber: Paladox.Nov 7 2018, 19:01

I've seen that too, possibly a bug. Filled upstream at https://phabricator.wikimedia.org/T208983

Paladox closed this task as Resolved.Nov 25 2018, 18:16
Paladox claimed this task.

This seems to work now.

MacFan4000 reopened this task as Open.Dec 11 2018, 20:23
MacFan4000 removed Paladox as the assignee of this task.
MacFan4000 added a subscriber: MacFan4000.

I can verify that this is still an issue.

Ahmsaqib updated the task description. (Show Details)Dec 14 2018, 13:24
AmandaCath changed the task status from Open to Stalled.Dec 31 2018, 17:58
AmandaCath added a project: Upstream.

Seconding MacFan that this still does occur. Appears to be an upstream issue.

In T3751#72015, @Xenic wrote:

Is there a way for me to "reset" mobile view?

What do you mean by this?

Corey added a subscriber: Corey.Jan 1 2019, 23:33

The page is displaying correctly for me.

Corey added a comment.Jan 5 2019, 20:15

The page is still showing properly for me.

@MacFan4000 @AmandaCath is this still an issue for y'all? If not, I'm going to mark this as resolved.

@Corey try looking at the Stewards Noticeboard in the mobile view.

Paladox added a comment.Jan 12 2019, 01:40

Now that we have upgraded to MediaWiki 1.32, is this still a problem?

Not able to reproduce this bug anywhere.

Programario added a comment.EditedJan 12 2019, 03:20


I confirmed it now. There was no problem.

Ahmsaqib closed this task as Resolved.Jan 12 2019, 06:04
Ahmsaqib claimed this task.

it's now resolved, maybe because of upgrading...