Page MenuHomeMiraheze

Upgrade to MediaWiki 1.32
Closed, ResolvedPublic

Description

As usual it's that time of year when there's a MediaWiki upgrade. We should upgrade because it may fix performance problems with ATT main page (not 100% sure but results look promising).

Also issues with actor are fixed with PageTriage which is causing some wikis to fatal (if they go to that specific api)

Event Timeline

Paladox created this task.Nov 12 2018, 22:17
John added a comment.Nov 12 2018, 22:18

We should upgrade because we commit to the latest version.

Reasons are irrelevant.

NDKilla added a comment.Nov 12 2018, 22:28
In T3794#72741, @John wrote:

We should upgrade because we commit to the latest version.

Reasons are irrelevant.

This.

But also didn't the 1.32 rc.0 just come out?

AmandaCath added a subscriber: AmandaCath.

Hmm... am I missing something here? I haven’t seen anything on the mw mailing list about a new version release, and the version lifecycle on MediaWiki.org still displays 1.31 as the latest version. To make things even stranger the lifecycle timeline jumps from 1.31 to 1.33 (skipping 1.32 altogether). Anyone have any insight?

John added a comment.Nov 14 2018, 02:41

1.32 is in RC stages, so it's not a formal release yet but it's no longer in alpha (which is 1.33).

Reception123 triaged this task as Normal priority.Nov 16 2018, 16:38

Normal priority until its out.

Paladox added a comment.Nov 26 2018, 21:58

Just leaving a FYI, this is a high priority once released. Seeing as initial tests show performance improvements (re att slow main page loading).

John added a comment.Nov 26 2018, 23:21

Just leaving a FYI, this is a high priority once released.

They’re always high priority when released

Paladox claimed this task.Nov 27 2018, 19:15

Housekeeping note, appears that this will be done very soon per 7f8ee98cf628

MacFan4000 closed this task as Resolved.Jan 11 2019, 12:33
AmandaCath reopened this task as Open.Jan 11 2019, 12:33

Not yet - T3982

MacFan4000 closed this task as Resolved.EditedJan 11 2019, 13:01

A wiki erroring doesn’t mean that the upgrade hasn’t been done. It’s just an issue caused by this being done.

John moved this task from Backlog to MediaWiki on the Goal-2019-Jan-Jun board.Jan 16 2019, 20:05