Page MenuHomeMiraheze

Fix default Chinese variant when visiting a translation to Chinese.
Closed, InvalidPublic

Description

Previous discussion on meta (See message by Laundry Machine)

Currently, users are allowed to create translation to Chinese (zh) and variants of Chinese (zh-cn, zh-hk, etc.). MediaWiki is able to show "zh" translations in different variants via a conversion function so that users can read "zh" translation in the variant they are used to. On zh.wikipedia.org, MediaWiki shows the variant the user selects in Special:Preferences by default. However, on Miraheze, it shows "No conversion" by default which may force users to make extra clicks to read comfortably.

It would be awesome if MediaWiki shows the variant user preferred in translation to "zh".

Event Timeline

Tiger created this task.Jan 20 2019, 04:47
Tiger updated the task description. (Show Details)Jan 21 2019, 11:19
Paladox added a comment.Feb 2 2019, 14:24

Nope. So there must be a missing config or this was recently added upstream.

John closed this task as Invalid.Feb 4 2019, 02:09
John added a subscriber: John.

Nope. So there must be a missing config or this was recently added upstream.

This has been in MediaWiki core since 2004 (1.3.4).

Now on the to issue, I've looked into this and I'm not able to understand the issue. On Special:Preferences, users are able to select the variant they prefer on zh language wikis. To me, this is correct behaviour, emulate zh.wikipedia.org and is what is described by the task.

Without further information, steps to reproduce and an accurate problem description - this seems to be working as intended.

For blacklisting, please open a task for blacklisting translation on the relevant wikis requested.

Tiger added a comment.EditedFeb 5 2019, 11:40
In T4029#77943, @John wrote:

Nope. So there must be a missing config or this was recently added upstream.

This has been in MediaWiki core since 2004 (1.3.4).

Now on the to issue, I've looked into this and I'm not able to understand the issue. On Special:Preferences, users are able to select the variant they prefer on zh language wikis. To me, this is correct behaviour, emulate zh.wikipedia.org and is what is described by the task.

Without further information, steps to reproduce and an accurate problem description - this seems to be working as intended.

For blacklisting, please open a task for blacklisting translation on the relevant wikis requested.

Sorry for unclear description above. Here is a screenshot of a "zh" translation. There is a conversion menu on the left by which readers can change to other variants. MediaWiki running on Miraheze shows option 1 (No conversion) by default, but showing option 2, 3 or other variants (zh-cn, zh-hk, etc) by default is better (according to the variant user selected in Special:Preferences).