Page MenuHomeMiraheze

Extension: Page Forms
Closed, ResolvedPublic

Description

Hi,

I've noticed over the last few days that Extension:Page Forms has stopped working correctly. For example I have set on a "field tag" the parameter "mandatory". This was working fine up until a few days ago (at least I noticed it then) and now it ignores the parameter. Also the parameter "unique" doesn't work.

Is there anything that could have been changed on the core system or could it be an extension that clashes with it. I can't see it being an extension unless it clashes with "group sidebar"

As an aside - I took off group sidebar (just in case) and on submit I got this message >> [2b0f72d9ae50d2d9b928f5f7] 2019-02-27 19:07:06: Fatal exception of type "Error". I also took off Page Forms and re-applied to see if that helped and got the above error for that too.

Event Timeline

Just to add to this, I think the problem is more likely on the Cargo side. I say this because those parameters are passed to the Template "Cargo_Store" function from Page Forms against the field. I added the parameters directly into the Cargo Store statement to see if they worked in that scenario and they didn't.

Void triaged this task as Low priority.Feb 28 2019, 02:03
Void added projects: Extensions, Upstream.
Void moved this task from Backlog to Bugs on the Extensions board.Feb 28 2019, 02:03

It is now working! I could tell it was going to work because previously it had a processing circle of whirliness in the centre of the screen when you were creating a form and now it doesn't. I haven't closed this ticket. I'm interested as to whether someting happened overnight that sorted Cargo out?

Paladox added a subscriber: Paladox.Feb 28 2019, 14:14

I updated PageForms yesterday which brought in some fixes for PageForms.js.

Michaeldakin closed this task as Resolved.Feb 28 2019, 14:15
Michaeldakin claimed this task.

Thanks @Paladox - I'll close this now.