Page MenuHomeMiraheze

Migrate all wikis to elasticsearch
Closed, DeclinedPublic

Description

Per T4024 we have purchased a server for elasticsearch and various wikis have been migrated. We have gained critical disk space back on db4 and search funtionality has been improved. A quite stable setup so far.

This task tracks the process of migrating all wikis to elasticsearch:

  1. Set wmgUseCirrusSearch and wmgDisableSearchUpdate to true for wiki
  2. Run php /srv/mediawiki/w/extensions/CirrusSearch/maintenance/updateSearchIndexConfig.php --wiki <wiki>
  3. Set wmgDisableSearchUpdate to false
  4. Run php /srv/mediawiki/w/extensions/CirrusSearch/maintenance/forceSearchIndex.php --skipLinks --indexOnSkip --wiki <wiki>
  5. Run php /srv/mediawiki/w/extensions/CirrusSearch/maintenance/forceSearchIndex.php --skipParse --wiki <wiki>
  6. Finally, set wmgSearchType to true for the wiki

Event Timeline

Southparkfan triaged this task as Normal priority.Apr 9 2019, 20:20
Southparkfan created this task.
Paladox added a subscriber: Paladox.Apr 9 2019, 21:12

Is it not possible to do a mass migration using foreachindblist?

Paladox added a comment.Apr 13 2019, 17:00

Nope, since we need to monitor the migration since we have over 3,000 wikis that well may use up all of ES disk.

Southparkfan raised the priority of this task from Normal to High.Jun 2 2019, 22:52

Saturday the Site went down again due to a mysql failure caused by insufficient disk space. This should be done sooner.

Paladox closed this task as Declined.Aug 1 2019, 00:46

We are not going with ElasticSearch at the moment.

Needs more resources then we can currently fund.

John added a subscriber: John.

A goal even declined is still a goal.