Page MenuHomeMiraheze

Restoration of the previous permissions of all wikis
Closed, ResolvedPublic

Description

I would like to request for restoring permissions across wikis. Although we can restore them through ManageWikiPermissions manually, I have found out that all the customized user groups has been completely deleted, and it looks like all the permissions has been reseted to the default permissions.

This will cost a lot of unnecessary work for many local bureaucrats. I believe there is a back up for this, and thus would want to have all the permissions restored as the permissions we used to have before the incident at the system level.

Event Timeline

The_Pioneer raised the priority of this task from Normal to High.May 23 2019, 00:49

Apparently, the Wiki Manager permission doesn't work as intended (while wiki creator, CVT, and interwiki-admin works fine). I will report this as an update.

John assigned this task to Paladox.May 23 2019, 01:44
Paladox added a comment.May 23 2019, 18:07

I've successfully managed to restore mw_permissions from a backup we had.

Paladox closed this task as Resolved.May 23 2019, 18:56