Page MenuHomeMiraheze

Update PDF Rendering for nenawiki.org and ndg.nenawiki.org
Open, NormalPublic

Description

Please install Proton in nenawiki.org and ndg.nenawiki.org.

Thanks!

Event Timeline

MikeV created this task.Jun 6 2019, 13:10

@MikeV Are you referring to your private wiki only or also your public wiki?

MikeV added a comment.Jun 7 2019, 20:41

Both are indicated in the title. What's the correct way to identify the site(s)?

Paladox added a subscriber: Paladox.Jun 7 2019, 20:54

You won't be able to use pdf rendering on https://ndg.nenawiki.org/wiki/Main_Page (as it's private and rest base only supports public wikis).

https://nenawiki.org/wiki/Main_Page Doesn't appear to have electron enabled (but if you do enable it, you can use pdf rendering). You can also enable Collection (PDF) too.

MikeV added a comment.Jun 7 2019, 21:03

Thanks. I didn't know that it is not supported on private sites. I was going to test it there before enabling it on the public site.

I still get this error on nenawiki.org:

We have technical problems with the function we use to create PDFs. We unfortunately have to replace it. This affects the styling and features of the books function. For more information and feedback, visit the project page.

    Leave feedbackRead more

When you go to the link indicated, you get the message that I referenced earlier about a new PDF rendering thing:

PDF Rendering has been improved as of 6/4/2019: https://www.mediawiki.org/wiki/Reading/Web/PDF_Functionality

Paladox added a comment.Jun 7 2019, 23:29

@MikeV works for me (i restarted the electron service).

MikeV added a comment.EditedJun 8 2019, 02:12

When I go to this page: https://nenawiki.org/wiki/EIDO_%26_IDX_FAQ_(Frequently_Asked_Questions)

and click on "Download as PDF", I get the error

. This happens whether or not I sign in and so far on both Firefox and Chrome.

Please note... MediaWiki says they deployed a new renderer on June 4, 2019, only a few days ago.

https://www.mediawiki.org/wiki/Reading/Web/PDF_Functionality#Update_on_PDF_rendering,_June_4,_2019

Has Miraheze installed it?

Paladox added a comment.Jun 8 2019, 20:42

@MikeV even though it says that, if you click download, it will work. That message is for the older infrastructure. We use Electron. And the post is for the newer infrastructure (newer then electron which we haven't installed yet).

MikeV added a comment.Jun 8 2019, 21:54

Error messages like this confuse, annoy, and discourage many of our users. Can we fix it?

John closed this task as Invalid.Jun 13 2019, 00:39
John added a subscriber: John.

This would be an issue to take upstream.

MikeV added a comment.Jun 13 2019, 18:25

John, does this mean that Miraheze is up-to-date on the PDF rendering changes from MediaWiki on June 4?

Paladox added a comment.EditedJun 13 2019, 22:04

@MikeV hi, nope We use "Electron" which predates "Proton". (i.e "proton" is the newer infrastructure) which i plan to upgrade to later.

MikeV added a comment.Jun 14 2019, 01:33

OK. I don't know the correct protocol or etiquette to follow here. Do I change this task to request installation of Proton or do I abandon this task and start a new one to request Proton? Put another way, what is the best way to get a better PDF rendering capability?

Paladox added a comment.Jun 14 2019, 13:46

You can change this to requesting the installation of "Proton".

MikeV reopened this task as Open.Jun 14 2019, 13:56
MikeV updated the task description. (Show Details)

@Paladox What's the status on the Proton upgrade? When will it be done?

Paladox added a comment.Jun 16 2019, 19:02

I need to install it, then replace it in RESTBASE.

Note that proton still uses RESTBASE so private wikis will still not work.

MikeV added a comment.Jun 25 2019, 14:04

PDF rendering is becoming a critical factor with our users. An update on status would be appreciated. Thanks.

AmandaCath triaged this task as High priority.Jul 3 2019, 13:22
AmandaCath added a subscriber: AmandaCath.
In T4445#85252, @MikeV wrote:

PDF rendering is becoming a critical factor with our users. An update on status would be appreciated. Thanks.

I need to install it, then replace it in RESTBASE.
Note that proton still uses RESTBASE so private wikis will still not work.

@Paladox Status on this?

Paladox added a comment.Jul 8 2019, 11:54

Update: I would like to install that very soon. I just need to look at the install docs and try to install it.

Paladox lowered the priority of this task from High to Normal.Jul 20 2019, 17:42

PDF rendering works using electron, i'm not seeing the problem (so lowering the priority to normal on this task).

MikeV added a comment.Jul 20 2019, 18:37

A few points:

  • Electron generates an error message that users believe. It discourages them from continuing to "Download as PDF."
  • If you ignore the error, it creates PDFs that cannot be used without editing. For example, it now inserts a block that says "Cookies help us deliver out services. By using our services, you agree to our use of cookies. More Information OK." This message overwrites the PDF material.
  • This page indicates that Proton has apparently been successfully deployed as an improvement to electron: https://www.mediawiki.org/wiki/Reading/Web/PDF_Functionality

We appreciate any effort to fix the "Download as PDF" function. We hope that changing the priority from High to Normal doesn't result in significant delays in deployment.

Thanks.

Paladox added a comment.EditedJul 20 2019, 19:22

Oh, that's the extension it's self (which the new renderer still uses).

The extension has had that message removed (https://github.com/wikimedia/mediawiki-extensions-ElectronPdfService/commit/1f0494a6a8d6e3d6fa2349b7d43d2ee457c45e3b).

MikeV added a comment.Aug 20 2019, 20:47

Sorry, Paladox. I do not understand your response.

Please go to this page and then click "Download to PDF" from the menu: https://nenawiki.org/wiki/NENA_NG9-1-1_Go-To_Handbook_(Review_Draft)

First, you get an error message. Then the downloaded PDF not acceptable.

Now, if you go to the Widipedia page for PDF, and click "Downlad to PDF", you don't get the error message and you get a good downloaded PDF version of the page.

Can Miraheze make our "Download to PDF" work as well as Wikipedia does?

Paladox added a comment.Aug 20 2019, 21:05

I tried to install the new pdf renderer but couldn’t get it to work. So will need to work on that again.

Please try to do this ASAP

And also to point out, I just tried to download a PDF and it worked.

MikeV added a comment.Aug 21 2019, 12:53

Reception, Please look at it. There's a banner at the top of the screen that doesn't belong: "Cookies help us deliver ou tservices. By using our sevices, you agree to our use of cookies. More information OK".

So there are two problems... Error message and banner.

These two problems do not happen for "Download to PDF" on Wikipedia.

@Paladox is it possible to exempt IPs/services from the cookie warning so that it no longer appears on the generated PDF?

@MikeV I hope I'm understanding correctly, but is your issue only that there's an error message before you click the download button? If that is the case that can be removed by editing https://nenawiki.org/wiki/MediaWiki:ElectronPDFService-warning-message

@Paladox is it possible to exempt IPs/services from the cookie warning so that it no longer appears on the generated PDF?
@MikeV I hope I'm understanding correctly, but is your issue only that there's an error message before you click the download button? If that is the case that can be removed by editing https://nenawiki.org/wiki/MediaWiki:ElectronPDFService-warning-message

Oh, I've found the answer to my first question. That seems to depend on Upstream task: https://phabricator.wikimedia.org/T193716

This comment was removed by Reception123.

Technical comment:

ping @Southparkfan

We've tried blacklisting restbase so that when the service captures the page it ignores CookieWarning but that seems to not be working with REMOTE_ADDR due to Varnish (It works on test1).

@MikeV It seems that we have made it work. Could you please check and confirm that it works as intended for you?

MikeV added a comment.Aug 31 2019, 16:42

A test of a downloaded PDF now does not show the warning banner. Thank you for fixing this.

In T4445#89202, @MikeV wrote:

A test of a downloaded PDF now does not show the warning banner. Thank you for fixing this.

You're welcome! Do you still need anything else regarding the PDF function?