Page MenuHomeMiraheze

Data has disappeared on Usopedia
Closed, ResolvedPublic

Description

Data has disappeared!

In Usopedia (https://newusopedia.miraheze.org/wiki/), data of many articles have disappeared.

First, we use the Special:Replacetext to move an article that already exists "ウソニュース:" to "ウソニュース仮移転処理:" to create the "ウソニュース:" namespace, and then I made the "ウソニュース:" namespace from Special:ManageWiki/namespaces. Then, I tried to move "ウソニュース仮移転処理:" to "ウソニュース:" using Replacetext.

Then, the article which had been moved became a red link, and it could not be seen (it could be viewed for a while). All the same "ウソブックス" moved have disappeared.

We believe that the lost data is still left somewhere. Therefore, I would like to ask everyone to recover the data.

Event Timeline

Schwarz triaged this task as High priority.Jun 10 2019, 23:04
Schwarz created this task.
Schwarz added a comment.Jun 10 2019, 23:22

P.S. The data is gone when I try to create the "ウソディクショナリー" namespace. When I created it with Special:ManageWiki/namespaces in the same way as the previous two, articles of ウソニュース and ウソブックス have disappeared.

Paladox closed this task as Resolved.Jun 11 2019, 00:44
Paladox claimed this task.
Paladox added a subscriber: Paladox.

Hello,

We have debugged this and have found the cause. We have implemented a fix so this dosn't happen with any new namespaces. But existing namespaces will need to be updated with the correct name.

The problem was we were using the wrong encoding in the DB that broke things php side.

I've gone ahead and fixed one of your namespaces to confirm and it now works (ウソニュース)!

Schwarz added a comment.Jun 11 2019, 00:58

Thank you for your work.

But what happens to the missing articles? If data is left, please restore it.

Paladox added a comment.EditedJun 11 2019, 00:59

@Schwarz if you fix the namespace names it the data will be restored :).

(It was wrongly encoded in the db, so all you have to do is update the name to fix the encoding issue)

Schwarz added a comment.Jun 11 2019, 01:21

Thank you! I confirmed the recovery of ウソニュース.

I would like to ask, but can you restore ウソブックス and ウソディクショナリー?

Paladox added a comment.Jun 11 2019, 02:27

You can do that by editing the name of the ns through Special:ManageWikiNamespaces :)

Schwarz added a comment.Jun 11 2019, 03:34

OK, thank you!