Page MenuHomeMiraheze

Cargo extension
Open, NormalPublic

Description

Hi !
It"s me., again
Cartgo extension does not work
It creates the table but cannot put any data in it
I think it as to do with background task
The porportion is set to 0 in Miraheze settings, so background jobs never starts
I've found some documentation that suggest that end a user like me could make change to LocalSettings.php
Looks dangerous ....

my wiki is cllinlab

Thanks

Event Timeline

Levreauj created this task.Jul 28 2019, 03:12

Hi,
If you need something adding to LocalSettings we can do that for you. Anyone can find the file at https://github.com/miraheze/mw-config/blob/master/LocalSettings.php and make pull requests but only Operations can push changes

RhinosF1 triaged this task as Normal priority.Jul 28 2019, 05:13
RhinosF1 added a project: Extensions.
RhinosF1 edited projects, added MediaWiki; removed Extensions.Jul 28 2019, 05:13
RhinosF1 edited projects, added Extensions, Configuration; removed MediaWiki.
Paladox added a comment.Jul 29 2019, 00:59

All that script does is create the tables (which we do when you enable the extension)

Also @Levreauj when you say data does not get inserted in the table, do you get an error?

Levreauj added a comment.Aug 7 2019, 01:41

No it jsut does not do anything
See what I found in the cargo extension page
https://www.mediawiki.org/wiki/Extension:Cargo/Storing_data#Web-based%20tab
"Depending on the MediaWiki configuration, a call to MediaWiki's runJobs.php script may be useful or even necessary for these jobs to actually start."
Thanks !

I have tried to run the script, but that did not help since it is ran anyway by the jobrunner.

MJL awarded a token.Aug 7 2019, 19:41