Page MenuHomeMiraheze

Unhandled exception on Phabricator Badges
Closed, ResolvedPublic

Description

If you go to someone's user profile and click badges you will see the below error (example link: https://phabricator.miraheze.org/people/badges/1434/)

Event Timeline

RhinosF1 triaged this task as Normal priority.Wed, Aug 7, 22:26
RhinosF1 created this task.

Strange, I can't reproduce, I just get "User has not been awarded any badges."

Sure it wasn't just a one-time thing?

RhinosF1 added a comment.Thu, Aug 8, 08:09

Strange, I can't reproduce, I just get "User has not been awarded any badges."
Sure it wasn't just a one-time thing?

Nope, still seeing it

Log indicates:

php.log:[08-Aug-2019 08:09:18 UTC] [2019-08-08 08:09:18] EXCEPTION: (Exception) Query (of class "PhabricatorBadgesQuery") overheated: examined more than 10 raw rows without finding 1 visible objects. at [<phabricator>/src/infrastructure/query/policy/PhabricatorPolicyAwareQuery.php:339]
RhinosF1 changed the task status from Stalled to Open.Thu, Aug 8, 20:11

@RhinosF1 I've upgraded Phabricator again though not sure if the change was included (since the changelog doesn't indicate it) so please give it another try

@RhinosF1 I've upgraded Phabricator again though not sure if the change was included (since the changelog doesn't indicate it) so please give it another try

Will look tonight :)

@RhinosF1 I've upgraded Phabricator again
though not sure if the change was included (since the changelog doesn't indicate it)

This https://secure.phabricator.com/w/changelog/2019.32/ ?
It's the top 2 in the minor section that fix this sort of issue. Both for badges and projects.

so please give it another try

Reception123 closed this task as Resolved.Wed, Aug 14, 17:27
Reception123 claimed this task.

heh, must've read the wrong one or missed it :P In that case resolved.