Page MenuHomeMiraheze

Dark Theme for Vector Workaround, Math Equations still dark
Closed, InvalidPublic

Description

Hi,

Only my wiki willdonahue.miraheze.org, I edited the common.css with a dark theme. I want to say I found it in one of the phabricator tasks, but I honestly don't remember which. The issue I have is that my math equations are all showing up black on the dark background. I seem to have figured out the rest of it but can't seem to override this.

Seeing as how I am not and HTML/CSS guy, I was wondering if you might have some insight into the correct way to make this modification.

Thanks,

Will

Related Objects

Event Timeline

Donahuw2 created this task.Aug 22 2019, 16:25
Void added a comment.Aug 23 2019, 02:12

It's in the math extension, I don't know how to change the color of the generated png.

RhinosF1 triaged this task as Normal priority.Aug 23 2019, 16:56

I don't think this is possible at the moment as it's a PNG that's generated. I'll double check with someone else but if not we have to Upstream this.

Spoke to @Void, were going to upstream for a way to edit the background and text colour easily.

RhinosF1 changed the task status from Open to Stalled.Aug 23 2019, 17:10
RhinosF1 moved this task from Backlog to Blocked by upstream on the Configuration board.
Reception123 lowered the priority of this task from Normal to Low.Nov 30 2019, 06:42

Status to low since strictly upstream.

Reception123 closed this task as Invalid.Apr 11 2020, 17:51

Per our new Phabricator policy, tasks which we cannot do anything about due to them being blocked by the developers will be invalid on our side. Since there is absolutely nothing we can do about this and we are waiting on someone else, there is no point in tracking them here. Once the issue is fixed we will upgrade the extension/mediawiki and the issue will be resolved. We will make sure to let you know when that is the case.