Page MenuHomeMiraheze

Math not Rendering Correctly in wiki but does in the visual editor
Closed, InvalidPublic

Description

So here is a fun one. I have added a bunch of equations to my page. After saving the edits, I get all my equations rendered as '"UNIQ--postMath-0000XXXX-QINU`"' ` where XXXX is the equation number in the page. However, when I open the page for editing using the visual editor, they all get rendered correctly. It does not appear to be an issue on my sandbox however. I figure it has to be a syntax error somewhere but I am not seeing where it is. The fact that it renders in the editor makes it seem like the equations should all work.

Page in question: https://willdonahue.miraheze.org/wiki/AAPM_TG-51

It should be noted that this page was edited during today's system outage.

Event Timeline

Donahuw2 created this task.Sep 30 2019, 18:24
Donahuw2 added a comment.Oct 1 2019, 17:54

Ok so I figured out the cause... I have a template that adds the code "{{Special:WhatlinksHere/{{FULLPAGENAME}}}}" It appears that this breaks the generation of equations. As masters of the Wiki, do you have any ideas?

Southparkfan changed the task status from Open to Stalled.Oct 17 2019, 11:12
Southparkfan added a project: Upstream.
Southparkfan added a subscriber: Southparkfan.

Hi @Donahuw2, thanks for your analysis. This seems to be a bug in the Math extensions and requires a fix from the developers. I have added a comment to the bug, which seems to be known for over three years.

Southparkfan triaged this task as Low priority.Oct 17 2019, 11:12
Reception123 closed this task as Invalid.Apr 11 2020, 17:59
Reception123 added a subscriber: Reception123.

Per our new Phabricator policy, tasks which we cannot do anything about due to them being blocked by the developers will be invalid on our side. Since there is absolutely nothing we can do about this and we are waiting on someone else, there is no point in tracking them here. Once the issue is fixed we will upgrade the extension/mediawiki and the issue will be resolved. We will make sure to let you know when that is the case.