Page MenuHomeMiraheze

Comment function does not work
Open, NormalPublic

Description

There is a problem that can not be commented on Shiropedia. Please correct as soon as possible.

https://shiropedia.miraheze.org/wiki/%E3%83%A1%E3%82%A4%E3%83%B3%E3%83%9A%E3%83%BC%E3%82%B8

Related Objects

Event Timeline

J-Josyu created this task.May 16 2020, 10:21
Reception123 triaged this task as Normal priority.May 16 2020, 16:37
Reception123 added a project: Extensions.
Reception123 added a subscriber: Reception123.

Hi. Could you please link the page where it doesn't work? You linked the Main Page and I don't see any <comments /> tags there.

J-Josyu added a comment.May 17 2020, 00:29

All pages that use the comment function.

Paladox added a subscriber: Paladox.May 17 2020, 01:26

Hi, please could you explain what the issue is exactly? What's not working (e.g error name/code). And how do we reproduce?

I just posted a comment and it worked for me.

J-Josyu added a comment.May 17 2020, 01:42

I can't comment even if I press the post comment button.

J-Josyu added a comment.May 17 2020, 01:45

Is it just my environment? On other wikis I can comment on my device too.

That is weird, because I am able to comment on the wiki you have mentioned.

Is it just my environment? On other wikis I can comment on my device too.

Please can you give us your OS & Browser Version

J-Josyu added a comment.May 18 2020, 08:56

Only Shiropedia can't comment, other wikis can comment normally.

J-Josyu added a comment.May 18 2020, 23:34

Users in Japan may not be able to comment. My friends couldn't comment either

J-Josyu added a comment.Jun 21 2020, 12:19

Since there was no progress, I uncommented the comment extension and re-inserted it, but an error occurred.

J-Josyu added a comment.Jun 21 2020, 12:19

[257ddcbd6f56612ec9a0ca1c] 2020-06-21 12:17:40: 種別「Error」の致命的例外

J-Josyu added a comment.Jun 21 2020, 12:22

This error occurs when editing.

Paladox added a comment.Jun 21 2020, 14:48
2020-06-21 12:17:40 mw5 shiropediawiki: [257ddcbd6f56612ec9a0ca1c] /w/index.php?title=%E5%9F%8E%E3%83%9A%E3%83%87%E3%82%A3%E3%82%A2:%E6%97%A5%E5%B8%B8%E4%BC%9A%E8%A9%B1&action=edit   Error from line 245 of /srv/mediawiki/w/extensions/Comments/includes/CommentsPage.php: Call to private Comment::__construct() from context 'CommentsPage'
#0 /srv/mediawiki/w/extensions/Comments/includes/CommentsPage.php(480): CommentsPage->getComments()
#1 /srv/mediawiki/w/extensions/Comments/includes/parser/DisplayComments.php(83): CommentsPage->display()
#2 /srv/mediawiki/w/includes/parser/Parser.php(4293): DisplayComments::getParserHandler(NULL, array, Parser, PPFrame_Hash)
#3 /srv/mediawiki/w/includes/parser/PPFrame_Hash.php(328): Parser->extensionSubstitution(array, PPFrame_Hash)
#4 /srv/mediawiki/w/includes/parser/Parser.php(3330): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#5 /srv/mediawiki/w/includes/parser/Parser.php(1489): Parser->replaceVariables(string)
#6 /srv/mediawiki/w/includes/parser/Parser.php(593): Parser->internalParse(string)
#7 /srv/mediawiki/w/includes/content/WikitextContent.php(368): Parser->parse(string, Title, ParserOptions, boolean, boolean, NULL)
#8 /srv/mediawiki/w/includes/content/AbstractContent.php(555): WikitextContent->fillParserOutput(Title, NULL, ParserOptions, boolean, ParserOutput)
#9 /srv/mediawiki/w/includes/EditPage.php(4120): AbstractContent->getParserOutput(Title, NULL, ParserOptions)
#10 /srv/mediawiki/w/includes/EditPage.php(4025): EditPage->doPreviewParse(WikitextContent)
#11 /srv/mediawiki/w/includes/EditPage.php(2811): EditPage->getPreviewText()
#12 /srv/mediawiki/w/includes/EditPage.php(703): EditPage->showEditForm()
#13 /srv/mediawiki/w/includes/actions/EditAction.php(55): EditPage->edit()
#14 /srv/mediawiki/w/includes/MediaWiki.php(511): EditAction->show()
#15 /srv/mediawiki/w/includes/MediaWiki.php(302): MediaWiki->performAction(Article, Title)
#16 /srv/mediawiki/w/includes/MediaWiki.php(900): MediaWiki->performRequest()
#17 /srv/mediawiki/w/includes/MediaWiki.php(527): MediaWiki->main()
#18 /srv/mediawiki/w/index.php(44): MediaWiki->run()
#19 {main}
2020-06-21 12:
Paladox closed this task as Resolved.Jun 21 2020, 22:27
Paladox claimed this task.

Fixed now.

J-Josyu added a comment.Jun 25 2020, 13:33

The form has been fixed, but I'm still unable to post comments. One month has already passed since the first request. I want to fix it as soon as possible.

J-Josyu reopened this task as Open.Jun 25 2020, 13:33
J-Josyu removed a subscriber: J-Josyu.
Paladox added a comment.Jun 25 2020, 13:42

What error do you get? How long do you wait?

Works for me on https://shiropedia.miraheze.org/wiki/城ペディア:情報交換所

J-Josyu added a comment.Jun 25 2020, 13:50

No matter how long I wait, the comment is not reflected.

J-Josyu added a subscriber: J-Josyu.Jun 27 2020, 12:00
Schwarz added a subscriber: Schwarz.Jul 11 2020, 08:24
Schwarz added a comment.Jul 11 2020, 08:28

I confirmed that the comment box and the submit button are reflected, but when I press the submit button, the comment is not reflected.

J-Josyu added a comment.Sun, Aug 2, 08:10

What are you doing Response is too late. It's funny to ignore opinions even if it's technically difficult.
Even if the conversation history disappears, please be sure to correct it.Quickly!!