Page MenuHomeMiraheze

Media Viewer error
Open, NormalPublic

Description

Media Viewer is unable to load image previews. Thumbnails display on published pages, but after clicking on image to open in Media Viewer, an error message occurs.

Private wiki is mlharchive.miraheze.org

Example is image on https://mlharchive.miraheze.org/wiki/MLH_Family_Archive_Main_Page.

Had same issue with pastport.org last month and was pleased to see it fixed quickly.

Related Objects

Event Timeline

AmandaCath triaged this task as Normal priority.Jun 7 2020, 21:30
AmandaCath added a project: Extensions.

The same issue was fixed for my other wiki under Task T5568.

Works for me, i think the first time it fetches it will fail (as it generates the thumb in the background). E.g when you fetch the image it'll start generating it but not before it 404s.

Fails for me with multiple attempts. More examples https://mlharchive.miraheze.org/wiki/Carroll_Gene_Hildebrand. No successful fetches today.

This is still a problem.

Hispano76 reopened this task as Open.Jul 14 2020, 12:51
Hispano76 closed this task as a duplicate of T5915: Media Viewer error.

@Markhild-mym Hi, please be patient, our volunteers will check it out when they can.

Any progress? Had the same issue with our public wiki (pastport.org). Created T5568 on May 10, 2020 and it was fixed the same day.

So it appears the issue is that the cookies header is not being forwarded (e.g your login token). Your wiki is private so requires to be logged in for the thumbnail to generate.

Does this mean that the wiki cannot be private for Media Viewer to work, or is it something that can be fixed?

This is Something that can be fixed.