Page MenuHomeMiraheze

Extension review: Contributors
Open, NormalPublic

Description

Hi Miraheze volunteer staff,
I was wondering whether it would be possible to add support for the stable Contributors extension to Miraheze wikis.

Thank you very much for your help and your efforts in this project :)

Event Timeline

Hi. The extension will need a security review.

Reception123 renamed this task from Could it be possible to add support for Extension:Contributors to Extension review: Contributors.Wed, Jul 8, 06:00
Reception123 moved this task from Backlog to Blocked by security review on the Configuration board.
Reception123 moved this task from Backlog to Review Needed on the Extensions board.

Latest version dating from 2015 - 5 years ago. Said latest version was developed for MediaWiki 1.25 (although it works in all later versions, I think). Possibly unmaintained.

Hi, thank you for the help!
Yes I did notice officially it appears it has not been updated from the extensions page.
But then I saw it seems much more active on their git repo, also by the latest code review.

I am not familiar with mediawiki extensions, or how they are dated (from repo activity or latest stable release), it may be that the old stable one is the only one available?
Thank you,

Hi, thank you for the help!
Yes I did notice officially it appears it has not been updated from the extensions page.
But then I saw it seems much more active on their git repo, also by the latest code review.

I am not familiar with mediawiki extensions, or how they are dated (from repo activity or latest stable release), it may be that the old stable one is the only one available?
Thank you,

You are correct that there do appear to be recent updates to the extension, but most of those updates appear to be just backend maintenance and not really changing or updating the extension at all. Additionally, the MediaWiki documentation uses the most recent stable release for the "latest version" dates - just small maintenance tasks that don't change how the extension operates for the average user are usually excluded (except for major security-related changes).

So, at the end of the day, the extension is not unmaintained per se, but the fact that the latest stable release is from over 5 years ago and was designed for MediaWiki 1.25 which is no longer supported may be a blocker. Pinging our two security reviewers for a further look. @Southparkfan @Samwilson

Yes I agree, in this sense it seems quite outdated indeed.