Page MenuHomeMiraheze

Temporarily remove Wikimedia Incubator from memesincubatorwiki
Closed, InvalidPublic

Description

The wiki is restricting me from making certain pages, so I want to temporarily remove the extension until I have my wiki fully set up the way I want it.

Event Timeline

WikiJS triaged this task as Normal priority.May 14 2021, 00:18
WikiJS created this task.
[548563a69457f581a732e3ff] /wiki/Special:MultiPageEdit   InvalidArgumentException from line 2493 of /srv/mediawiki/w/includes/libs/rdbms/database/Database.php: Wikimedia\Rdbms\Database::makeList: empty input for field page_title
#0 /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(1966): Wikimedia\Rdbms\Database->makeList(array, integer)
#1 /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(1905): Wikimedia\Rdbms\Database->selectSQLText(array, array, array, string, array, array)
#2 /srv/mediawiki/w/includes/libs/rdbms/database/DBConnRef.php(68): Wikimedia\Rdbms\Database->select(array, array, array, string, array, array)
#3 /srv/mediawiki/w/includes/libs/rdbms/database/DBConnRef.php(313): Wikimedia\Rdbms\DBConnRef->__call(string, array)
#4 /srv/mediawiki/w/includes/specialpage/QueryPage.php(475): Wikimedia\Rdbms\DBConnRef->select(array, array, array, string, array, array)
#5 /srv/mediawiki/w/includes/specialpage/QueryPage.php(655): QueryPage->reallyDoQuery(integer, integer)
#6 /srv/mediawiki/w/extensions/PageForms/specials/PF_MultiPageEdit.php(47): QueryPage->execute(NULL)
#7 /srv/mediawiki/w/includes/specialpage/SpecialPage.php(600): PFMultiPageEdit->execute(NULL)
#8 /srv/mediawiki/w/includes/specialpage/SpecialPageFactory.php(635): SpecialPage->run(NULL)
#9 /srv/mediawiki/w/includes/MediaWiki.php(307): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
#10 /srv/mediawiki/w/includes/MediaWiki.php(940): MediaWiki->performRequest()
#11 /srv/mediawiki/w/includes/MediaWiki.php(543): MediaWiki->main()
#12 /srv/mediawiki/w/index.php(53): MediaWiki->run()
#13 /srv/mediawiki/w/index.php(46): wfIndexMain()
#14 {main}

I'm sorry, but I'm not sure what that code means.

I'm sorry, but I'm not sure what that code means.

@WikiJS It's a stack trace to try and diagnose what the problem is, whether it's a configuration issue or an upstream bug, in order to try and resolve it. It could be a conflict with another extension on your wiki, too. Let's wait and see what they say and how easy it is to fix, then if it's not going to be an easy fix, you can ping me and I'll disable it for you.

Dmehus moved this task from Backlog to Short Term on the MediaWiki (SRE) board.
Dmehus moved this task from Unsorted to Short Term on the Universal Omega board.
Dmehus renamed this task from Temporarily remove Wikimedia Incubator from my wiki to Error returned with Wikimedia Incubator on memesincubatorwiki.May 14 2021, 01:25

But that stack trace has nothing to do with what they are saying the task is. And does not even have anything to do with Wikimedia Incubator.

That stack trace is page forms related not this. Maybe @Southparkfan meant to post that in T7302? which is what that stack trace should be in.

Universal_Omega renamed this task from Error returned with Wikimedia Incubator on memesincubatorwiki to Temporarily remove Wikimedia Incubator from memesincubatorwiki.May 14 2021, 07:38
Universal_Omega closed this task as Invalid.
Universal_Omega claimed this task.

Hello, please ask this on Stewards' noticeboard. Thanks!

But I would like to know how it is restricting you from editing some pages so we might resolve it instead of disabling it entirely, on your wiki?

I get this message

Error: This page is unprefixed! You can create a page at Wp/en/Main Page.

This page has been deleted. The deletion, protection, and move log for the page are provided below for reference.

(change visibility) 23:44, 13 May 2021 Bukkit talk contribs block deleted page Main Page (content was: "<templatestyles src="MediaWiki:MainPage.css" /> <div class="MainPage__row MainPage__header"> <div class="MainPage__block MainPage__intro"> <h1><translate><!--T:16--> Meta-Wiki</translate></h1> <div id="mf-intro" class="MainPage__block_contents"> <translate><!--T:8--> '''Welcome to [[<tvar|m-about>Special:MyLanguage/Meta:About</>|Meta-Wiki]]''', the global community site for the [[<tvar|wmf>Special:MyLanguage/Wikimedia Foundation</>|Wikimedia Foundation's]] <tvar|wm-projects>S...") (view/restore)
There is currently no text in this page. You can search for this page title in other pages, or search the related logs, but you do not have permission to create this page.

(I deleted the main page because I thought that was why Import wasn't importing to the main page)

I get this message

Error: This page is unprefixed! You can create a page at Wp/en/Main Page.

This page has been deleted. The deletion, protection, and move log for the page are provided below for reference.

(change visibility) 23:44, 13 May 2021 Bukkit talk contribs block deleted page Main Page (content was: "<templatestyles src="MediaWiki:MainPage.css" /> <div class="MainPage__row MainPage__header"> <div class="MainPage__block MainPage__intro"> <h1><translate><!--T:16--> Meta-Wiki</translate></h1> <div id="mf-intro" class="MainPage__block_contents"> <translate><!--T:8--> '''Welcome to [[<tvar|m-about>Special:MyLanguage/Meta:About</>|Meta-Wiki]]''', the global community site for the [[<tvar|wmf>Special:MyLanguage/Wikimedia Foundation</>|Wikimedia Foundation's]] <tvar|wm-projects>S...") (view/restore)
There is currently no text in this page. You can search for this page title in other pages, or search the related logs, but you do not have permission to create this page.

(I deleted the main page because I thought that was why Import wasn't importing to the main page)

Can you give an example of a page it happens on?

I think any uncreated page in the mainspace

That's what wikimedia incubator is supposed to do.

Yes, I know, but if I'm trying to do imports or adding a subpage it doesn't work at all.

You can't just import pages to a wiki with Wikimedia Incubator. The prefix is needed.

You can't just import pages to a wiki with Wikimedia Incubator. The prefix is needed.

Ah, that's what the issue was. I figured it was something like that, but wasn't sure exactly (likely something done wrong on-wiki).

I want to freely import pages without a prefix

You get me?

I don't believe that's possible, as the prefix is included as part of the page name, so it'll be included in the XML export. I can disable Wikimedia Incubator if you prefer not to use it

It's not a bad extension; it's just not a well designed extension. @revi may have something more to say on this

It's not a bad extension; it's just not a well designed extension

It's not badly designed. It just has an extremely narrow purpose.

You'd have to ask whoever does upstream new wikis imports on how to export from incubator.

WikiJS claimed this task.

I'll just request it to get removed until I set up all of the mainspace pages I need.

WikiJS removed WikiJS as the assignee of this task.May 14 2021, 19:34

@Bukkit Per your request on Libera.Chat on IRC via direct message, I have now removed the WikimediaIncubator extension. :)

Dmehus changed the task status from Declined to Invalid.Jun 1 2021, 04:23
Dmehus claimed this task.